# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 

inherit eutils

DESCRIPTION="NetAMS Traffic Accounting"
SRC_URI="http://www.netams.com/files/netams-${PV}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 amd64"
RDEPEND="dev-db/mysql net-libs/libpcap net-libs/libnetfilter_queue"

src_unpack() {
    unpack ${P}.tar.gz
    epatch ${FILESDIR}/netams-3.4.5-ds-compile.patch || die
}

src_compile() {
    ./configure.sh || die
    FLAGS=-DHAVE_BW make || die
}

src_install() {
    into /usr
    mkdir -p ${D}/usr/sbin
    mkdir -p ${D}/etc/init.d
    mkdir -p ${D}/usr/share/man/man8/
    mkdir -p ${D}/var/www/localhost/htdocs/netams/images
    
    install -m 0755 ${FILESDIR}/netams33.init ${D}/etc/init.d/netams || die
#    install -m 0755 addon/netams-gentoo.sh ${D}/etc/init.d/netams || die
    install -m 0755 src/flowprobe ${D}/usr/sbin/  || die
#    install -m 0755 src/ipfw2netflow ${D}/usr/sbin/ || die
#    install -m 0755 src/ulog2netflow ${D}/usr/sbin/ || die
    install -m 0755 src/netams ${D}/usr/sbin/ || die
    install -m 0755 src/netamsctl ${D}/usr/sbin/ || die
    install -m 0644 doc/*.8 ${D}/usr/share/man/man8/ || die
    install -m 0644 addon/netams.js ${D}/var/www/localhost/htdocs/netams/ || die
    install -m 0644 cgi-bin/images/* ${D}/var/www/localhost/htdocs/netams/images/ || die
}