summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdoardo Pasca <edo.paskino@gmail.com>2017-10-20 17:05:20 +0100
committerEdoardo Pasca <edo.paskino@gmail.com>2017-10-20 17:05:20 +0100
commite1df6bc9ab2f1e0d66cb7385d295b7cb66a2ea43 (patch)
tree0eb18786384a0585339ab0ce6be5d4771c76e59e /CMakeLists.txt
parent903175ed67f7645fa35edf4623b27999d6cb990f (diff)
parent966bc0b109a27b69033b16f0b98fbd25056f2f90 (diff)
downloadregularization-e1df6bc9ab2f1e0d66cb7385d295b7cb66a2ea43.tar.gz
regularization-e1df6bc9ab2f1e0d66cb7385d295b7cb66a2ea43.tar.bz2
regularization-e1df6bc9ab2f1e0d66cb7385d295b7cb66a2ea43.tar.xz
regularization-e1df6bc9ab2f1e0d66cb7385d295b7cb66a2ea43.zip
Merge branch 'pythonize' of https://github.com/vais-ral/CCPi-FISTA_Reconstruction into pythonize
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..d05cdd9
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Copyright 2017 Edoardo Pasca
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+cmake_minimum_required (VERSION 3.0)
+
+project(FISTA)
+#https://stackoverflow.com/questions/13298504/using-cmake-with-setup-py
+
+# The version number.
+set (FISTA_VERSION_MAJOR 1)
+set (FISTA_VERSION_MINOR 0)
+
+set (CIL_VERSION_MAJOR 0)
+set (CIL_VERSION_MINOR 9)
+set (CIL_VERSION_PATCH 1)
+
+set (CIL_VERSION '${CIL_VERSION_MAJOR}.${CIL_VERSION_MINOR}.${CIL_VERSION_PATCH}')
+
+add_subdirectory(src)