summaryrefslogtreecommitdiffstats
path: root/recipe/meta.yaml
diff options
context:
space:
mode:
authorTomas Kulhanek <tomas.kulhanek@stfc.ac.uk>2019-02-28 16:24:01 +0000
committerGitHub <noreply@github.com>2019-02-28 16:24:01 +0000
commit879c87c5709ee194a8c7a2207f5a21d4a757f723 (patch)
treeeddf7bc14a998ffabc7e9e01f0cca2ac44b1d88a /recipe/meta.yaml
parent4c728cf72345f7ab7967380cb536529fd9b1403d (diff)
parent68e6f3397e8a450854f39a5d514e1f747b9031a4 (diff)
downloadregularization-879c87c5709ee194a8c7a2207f5a21d4a757f723.tar.gz
regularization-879c87c5709ee194a8c7a2207f5a21d4a757f723.tar.bz2
regularization-879c87c5709ee194a8c7a2207f5a21d4a757f723.tar.xz
regularization-879c87c5709ee194a8c7a2207f5a21d4a757f723.zip
Merge pull request #104 from vais-ral/newdirstructure
New directory structure, Merged other changes. The build script checks old and new structure.
Diffstat (limited to 'recipe/meta.yaml')
-rw-r--r--recipe/meta.yaml43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipe/meta.yaml b/recipe/meta.yaml
new file mode 100644
index 0000000..6f36906
--- /dev/null
+++ b/recipe/meta.yaml
@@ -0,0 +1,43 @@
+package:
+ name: ccpi-regulariser
+ version: {{CIL_VERSION}}
+
+build:
+ preserve_egg_dir: False
+ number: 0
+ script_env:
+ - CIL_VERSION
+
+test:
+ files:
+ - ../test/lena_gray_512.tif
+ requires:
+ - pillow
+ - pillow=4.1.1 # [win]
+# command:
+# - unittest -d discover .... ../test
+
+requirements:
+ build:
+ - python
+ - numpy {{ numpy }}
+ - setuptools
+ - cython
+ - vc 14 # [win and py36]
+ - vc 14 # [win and py35]
+ - vc 9 # [win and py27]
+ - cmake
+
+ run:
+ - {{ pin_compatible('numpy', max_pin='x.x') }}
+ - python
+ - numpy
+ - vc 14 # [win and py36]
+ - vc 14 # [win and py35]
+ - vc 9 # [win and py27]
+ - libgcc-ng
+
+about:
+ home: http://www.ccpi.ac.uk
+ license: BSD license
+ summary: 'CCPi Core Imaging Library Quantification Toolbox'