summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@dside.dyndns.org>2012-08-18 04:20:18 +0200
committerSuren A. Chilingaryan <csa@dside.dyndns.org>2012-08-18 04:20:18 +0200
commit047cd8feb375de9528dd627e25961863acf4e10a (patch)
treee8bd694e50a3ce8caef3f17a10a05fa7ab3851dc /CMakeLists.txt
parenta577cc5b8ef1f477e21f5f1c867c2936f86afa62 (diff)
downloadpcitool-047cd8feb375de9528dd627e25961863acf4e10a.tar.gz
pcitool-047cd8feb375de9528dd627e25961863acf4e10a.tar.bz2
pcitool-047cd8feb375de9528dd627e25961863acf4e10a.tar.xz
pcitool-047cd8feb375de9528dd627e25961863acf4e10a.zip
Fixes building in non-standard dirs
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 11 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 80355c2..cb3be58 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,8 +26,17 @@ add_subdirectory(dma)
add_subdirectory(ipecamera)
add_subdirectory(pcitool)
+include_directories(
+ ${FASTWRITER_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${FASTWRITER_LIBRARY_DIRS}
+ ${UFODECODE_LIBRARY_DIRS}
+)
+
add_library(pcilib SHARED pci.c register.c kmem.c irq.c dma.c event.c default.c tools.c error.c)
-target_link_libraries(pcilib ufodecode dma ipecamera ${CMAKE_THREAD_LIBS_INIT})
+target_link_libraries(pcilib dma ipecamera ${CMAKE_THREAD_LIBS_INIT} ${UFODECODE_LIBRARIES} )
add_dependencies(pcilib dma ipecamera)
set_target_properties(pcilib PROPERTIES
@@ -40,7 +49,7 @@ set_target_properties(pcilib PROPERTIES
if (NOT DISABLE_PCITOOL)
add_executable(pci cli.c)
add_dependencies(pci pcitool)
- target_link_libraries(pci pcilib pcitool fastwriter)
+ target_link_libraries(pci pcilib pcitool ${FASTWRITER_LIBRARIES})
set_target_properties(pci PROPERTIES
LINK_FLAGS ${CMAKE_THREAD_LIBS_INIT}
)
@@ -50,7 +59,6 @@ endif (NOT DISABLE_PCITOOL)
# LINK_FLAGS "-Wl,pcitool/libpcitool.a"
#)
-
if(NOT DEFINED BIN_INSTALL_DIR)
set(BIN_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/bin")
endif(NOT DEFINED BIN_INSTALL_DIR)