summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@suren.me>2015-09-24 04:28:45 +0200
committerSuren A. Chilingaryan <csa@suren.me>2015-09-24 04:28:45 +0200
commit08a01723af9cd52c078d5ca6c38c34d375b39fa0 (patch)
tree6eadea9c67f4bb56a9e4ee09f4982efaf61deece /CMakeLists.txt
parent924adedb2928f5657c6668f606dbb3294b3c45da (diff)
parentae7f83a7948d8c3760f8019899a45e6ec90c2c6a (diff)
downloadpcitool-08a01723af9cd52c078d5ca6c38c34d375b39fa0.tar.gz
pcitool-08a01723af9cd52c078d5ca6c38c34d375b39fa0.tar.bz2
pcitool-08a01723af9cd52c078d5ca6c38c34d375b39fa0.tar.xz
pcitool-08a01723af9cd52c078d5ca6c38c34d375b39fa0.zip
Finalyze XML support and provide initial support for views (only descriptions so far)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4c4c0d8..bc922c3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,11 +33,19 @@ SET(ENV{PKG_CONFIG_PATH} "${LIB_INSTALL_DIR}/pkgconfig:$ENV{PKG_CONFIG_PATH}")
find_package(PkgConfig REQUIRED)
find_package(Threads REQUIRED)
+find_package(PythonLibs REQUIRED)
set(EXTRA_SYSTEM_LIBS -lrt)
check_include_files(stdatomic.h HAVE_STDATOMIC_H)
+find_path(UTHASH_INCLUDE_DIRS uthash.h PATH_SUFFIXES uthash)
+if (UTHASH_INCLUDE_DIRS)
+ message ("uthash is found at ${UTHASH_INCLUDE_DIRS}")
+else (UTHASH_INCLUDE_DIRS)
+ message (FATAL_ERROR "uthash is not found...")
+endif (UTHASH_INCLUDE_DIRS)
+
pkg_check_modules(LIBXML2 libxml-2.0 REQUIRED)
#Check in sibling directory
@@ -66,6 +74,7 @@ set(PCILIB_DEBUG_DIR "." CACHE PATH "Directory to write debug information")
add_subdirectory(dma)
add_subdirectory(protocols)
+add_subdirectory(views)
add_subdirectory(pcilib)
add_subdirectory(pcitool)
add_subdirectory(apps)