summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorzilio nicolas <nicolas.zilio@kit.edu>2015-07-01 16:18:45 +0200
committerzilio nicolas <nicolas.zilio@kit.edu>2015-07-01 16:18:45 +0200
commitf82813bfa40193aec07e013b029eec6dc092ecdd (patch)
tree4f6b814177a0750b2c2c37aa2b2e47ffefc27255 /CMakeLists.txt
parente2515f6e1a7b17addda4c558a0a6ca05b4ec6e55 (diff)
downloadpcitool-f82813bfa40193aec07e013b029eec6dc092ecdd.tar.gz
pcitool-f82813bfa40193aec07e013b029eec6dc092ecdd.tar.bz2
pcitool-f82813bfa40193aec07e013b029eec6dc092ecdd.tar.xz
pcitool-f82813bfa40193aec07e013b029eec6dc092ecdd.zip
registers and banks support in xml v1. pci -ll works fine, but got segfault on pci -r name and pci -r name gives 0 always. might be due to the order in pci.c ------> ask suren
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f397c6b..2b5a498 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,13 +11,16 @@ set(DISABLE_PCITOOL FALSE CACHE BOOL "Build only the library")
find_package(PkgConfig REQUIRED)
find_package(Threads REQUIRED)
+find_package(PythonLibs REQUIRED)
#Check in sibling directory
if (NOT DISABLE_PCITOOL)
pkg_check_modules(FASTWRITER fastwriter REQUIRED)
endif (NOT DISABLE_PCITOOL)
-add_definitions("-fPIC --std=c99 -Wall -O2 -gdwarf-2 -g3")
+pkg_check_modules(XMLLIB libxml-2.0 REQUIRED)
+
+add_definitions("-fPIC --std=c99 -Wall -O2 -gdwarf-2 -g3 -g")
#add_definitions("-fPIC --std=c99 -Wall -O2")
include(cmake/version.cmake)