summaryrefslogtreecommitdiffstats
path: root/pywrap/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'pywrap/CMakeLists.txt')
-rw-r--r--pywrap/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/pywrap/CMakeLists.txt b/pywrap/CMakeLists.txt
index bebdf2e..f1c909e 100644
--- a/pywrap/CMakeLists.txt
+++ b/pywrap/CMakeLists.txt
@@ -11,12 +11,12 @@ include_directories(
set(HEADERS pcipywrap.h)
#Creating python wrapping
-INCLUDE(${SWIG_USE_FILE})
-INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})
-SET(CMAKE_SWIG_FLAGS "")
+include(${SWIG_USE_FILE})
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+set(CMAKE_SWIG_FLAGS "")
-SWIG_ADD_MODULE(pcipywrap python pcipywrap.i pcipywrap.c)
-SWIG_LINK_LIBRARIES(pcipywrap ${PYTHON_LIBRARIES} pcilib)
+swig_add_module(pcipywrap python pcipywrap.i pcipywrap.c)
+swig_link_libraries(pcipywrap ${PYTHON_LIBRARIES} pcilib)
#install pcilib python wrapper into Python site packages folder
execute_process ( COMMAND python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()" OUTPUT_VARIABLE PYTHON_SITE_PACKAGES OUTPUT_STRIP_TRAILING_WHITESPACE)