summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@dside.dyndns.org>2008-11-20 16:36:55 +0000
committerSuren A. Chilingaryan <csa@dside.dyndns.org>2008-11-20 16:36:55 +0000
commitd32415e5026bfef4c2ab1d7e92b454d2b44d39b9 (patch)
treefb2cfda7b69a48f6ec785c1f1072ef4163c956e2 /debian/rules
parent3e18aa68aa582bf16cc1ccffdd2cf3b4ca8a3dbf (diff)
downloadlibrcc-d32415e5026bfef4c2ab1d7e92b454d2b44d39b9.tar.gz
librcc-d32415e5026bfef4c2ab1d7e92b454d2b44d39b9.tar.bz2
librcc-d32415e5026bfef4c2ab1d7e92b454d2b44d39b9.tar.xz
librcc-d32415e5026bfef4c2ab1d7e92b454d2b44d39b9.zip
Debian support by Ivan Borzenkov
Diffstat (limited to 'debian/rules')
-rw-r--r--debian/rules105
1 files changed, 105 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100644
index 0000000..5c21c69
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,105 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+# shared library versions, option 1
+version=0.2.6
+major=0
+# option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
+#version=`ls src/.libs/lib*.so.* | \
+# awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
+#major=`ls src/.libs/lib*.so.* | \
+# awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+ ./autogen.sh
+
+ #dh_auto_configure
+ ./configure --prefix=/usr --enable-force-dynamic-engines --disable-libtranslate
+
+ touch configure-stamp
+
+
+build: build-stamp
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+ $(MAKE)
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ test ! -f Makefile || $(MAKE) clean distclean distclean-am
+ rm -rf docs/api/html
+ rm -f examples/Makefile
+
+ dh_auto_clean
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/tmp
+ $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+ install -d $(CURDIR)/debian/tmp/usr/share/doc/librcc-dev
+ cd docs/api && doxygen Doxyfile && mv html $(CURDIR)/debian/tmp/usr/share/doc/librcc-dev
+ cp docs/LibRCC.sxd.pdf $(CURDIR)/debian/tmp/usr/share/doc/librcc-dev/LibRCC.sxd.pdf
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_python
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure