summaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@dside.dyndns.org>2005-07-20 14:06:53 +0000
committerSuren A. Chilingaryan <csa@dside.dyndns.org>2005-07-20 14:06:53 +0000
commit27a53acf7190d20985a927f19fb5d0e90ad25e60 (patch)
tree91b177aca82a7a1b9848bbb184b61975b66deb9e /examples/Makefile.am
parent2cdfde517e53ae2c7c3393a505e1f127e714fc59 (diff)
downloadlibrcc-27a53acf7190d20985a927f19fb5d0e90ad25e60.tar.gz
librcc-27a53acf7190d20985a927f19fb5d0e90ad25e60.tar.bz2
librcc-27a53acf7190d20985a927f19fb5d0e90ad25e60.tar.xz
librcc-27a53acf7190d20985a927f19fb5d0e90ad25e60.zip
Fixes
- Added 'rcc-gtk-config' program to examples - Fixed problems in autoconf configuration - Fixed bug in rccLocaleGetCharset - Fixed visibility of all items in gtkui
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index abf3ebb..15df761 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -2,9 +2,15 @@ bin_PROGRAMS= example
example_SOURCES= example.c
example_LDADD= ../src/librcc.la
-EXTRA_DIST= input-russian.txt rcc.xml rcc-example.xml
+if HAVE_GTK
+bin_PROGRAMS+= rcc-gtk-config
+rcc_gtk_config_SOURCES = rcc-gtk-config.c
+rcc_gtk_config_LDADD=../ui/librccgtk.la @GTK_LIBS@
+endif
+
+EXTRA_DIST= input-russian.txt rcc.xml rcc-example.xml mpg123-rcc.patch
test-russian: example
cat input-russian.txt | ./example
-INCLUDES = -I../src -I../ui
+INCLUDES = -I../src -I../ui @GTK_INCLUDES@