summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@suren.me>2020-09-03 03:00:30 +0200
committerSuren A. Chilingaryan <csa@suren.me>2020-09-03 03:00:30 +0200
commit5172421d248250b4ab3b69eb57fd83656e23a4da (patch)
treea499d9f1dd0b74b754816884a59927b3171656fc /src/CMakeLists.txt
parent7b2e6168b049be9e7852b2d364d897592eff69fc (diff)
downloadufo-roof-temp-master.tar.gz
ufo-roof-temp-master.tar.bz2
ufo-roof-temp-master.tar.xz
ufo-roof-temp-master.zip
This is unfinished work implemeting out-of-UFO network serversHEADmaster
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 720c18f..837a6fb 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -2,7 +2,6 @@ cmake_minimum_required(VERSION 2.6)
#{{{ Sources
set(ufofilter_SRCS
- ufo-roof-read-task.c
ufo-roof-build-task.c
ufo-roof-filter-task.c
ufo-roof-flat-field-correct-task.c
@@ -12,12 +11,11 @@ set(common_SRCS
ufo-roof-config.c
)
-set(roof_read_aux_SRCS
+set(roof_build_aux_SRCS
+ hw_sched.c
+ hw_thread.c
ufo-roof-read-socket.c
ufo-roof-read-file.c
- )
-
-set(roof_build_aux_SRCS
ufo-roof-buffer.c
)
@@ -30,7 +28,7 @@ set(ufofilter_LIBS
${UFO_LIBRARIES}
${OpenCL_LIBRARIES})
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu18 -pedantic -Wall -Wextra -fPIC -Wno-unused-parameter -Wno-deprecated-declarations")
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu18 -pedantic -Wall -Wextra -fPIC -Wno-unused-parameter -Wno-deprecated-declarations -g -gdwarf-2 -g3 -fno-omit-frame-pointer")
add_definitions(-D_FILE_OFFSET_BITS=64 -D_LARGE_FILES)
#}}}