summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..fe330b6
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,13 @@
+include_directories(${KIROCS_SOURCE_DIR})
+link_directories(${KIROCS_BINARY_DIR})
+
+add_library(libucakiro SHARED uca-kiro-camera.c)
+target_link_libraries(libucakiro ${KIROCS_DEPS})
+
+set_target_properties(libucakiro PROPERTIES
+ VERSION "${LIBKIROCS_VERSION_MAJOR}.${LIBKIROCS_VERSION_MINOR}"
+ SOVERSION ${LIBKIROCS_VERSION_PATCH}
+)
+
+install(FILES uca-kiro-camera.h DESTINATION ${KIROCS_BINDIR})
+install(TARGETS uca-kiro-camera LIBRARY DESTINATION ${LIBUCA_LIBDIR}/uca)