summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2016-02-17 09:32:55 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2016-02-17 09:32:55 +0100
commit85ed63d3e0a4d27b5b07b162ccb53d82c9c2305b (patch)
tree885d5db48d3373354ab7ea75f864b22362fd3212 /CMakeLists.txt
parent2cf4562e5540d0b275ba85427735a0e1d684484f (diff)
downloaduca-net-85ed63d3e0a4d27b5b07b162ccb53d82c9c2305b.tar.gz
uca-net-85ed63d3e0a4d27b5b07b162ccb53d82c9c2305b.tar.bz2
uca-net-85ed63d3e0a4d27b5b07b162ccb53d82c9c2305b.tar.xz
uca-net-85ed63d3e0a4d27b5b07b162ccb53d82c9c2305b.zip
Set port centrally and allow server override
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a864fd0..aa5ab7f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,7 +16,10 @@ pkg_check_modules(GIO gio-2.0>=2.22 REQUIRED)
pkg_check_modules(UCA libuca>=2.1.0 REQUIRED)
pkg_check_variable(libuca plugindir)
-include_directories(${CMAKE_CURRENT_SOURCE_DIR} ${UCA_INCLUDE_DIRS} ${GIO_INCLUDE_DIRS} ${MSGPACK_INCLUDE_DIRS})
+set(UCA_NET_DEFAULT_PORT 8989)
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config.h.in ${CMAKE_CURRENT_BINARY_DIR}/config.h)
+
+include_directories(${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR} ${UCA_INCLUDE_DIRS} ${GIO_INCLUDE_DIRS})
link_directories(${UCA_LIBRARY_DIRS} ${GIO_LIBRARY_DIRS})
# uca-net client camera