summaryrefslogtreecommitdiffstats
path: root/plugins/mock/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2012-09-28 18:16:56 +0200
committerMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2012-09-28 18:16:56 +0200
commit99b737ae9f3f1d35a4696594821fa3bc39e8aa87 (patch)
tree73ed9e59018d3a8181397d5ff4afa70d5029da9a /plugins/mock/CMakeLists.txt
parent0bc642a31600bbfaac15779b8d932a409283ae3f (diff)
downloaduca-99b737ae9f3f1d35a4696594821fa3bc39e8aa87.tar.gz
uca-99b737ae9f3f1d35a4696594821fa3bc39e8aa87.tar.bz2
uca-99b737ae9f3f1d35a4696594821fa3bc39e8aa87.tar.xz
uca-99b737ae9f3f1d35a4696594821fa3bc39e8aa87.zip
Fix #146: Make a new top-level directory for cams
... and build a package for each camera. Moreover, for some reason we can live without the CMake generated spec file for RPM generation. AFAICS, the RPMs are prefixed correctly.
Diffstat (limited to 'plugins/mock/CMakeLists.txt')
-rw-r--r--plugins/mock/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/plugins/mock/CMakeLists.txt b/plugins/mock/CMakeLists.txt
new file mode 100644
index 0000000..75d8635
--- /dev/null
+++ b/plugins/mock/CMakeLists.txt
@@ -0,0 +1,18 @@
+cmake_minimum_required(VERSION 2.8)
+project(ucamock)
+
+set(UCA_CAMERA_NAME "mock")
+
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/../package-plugin.sh.in
+ ${CMAKE_CURRENT_BINARY_DIR}/../../package-plugin-${UCA_CAMERA_NAME}.sh)
+
+add_library(ucamock SHARED
+ uca-mock-camera.c)
+
+target_link_libraries(ucamock
+ uca
+ ${UCA_DEPS})
+
+install(TARGETS ucamock
+ LIBRARY DESTINATION ${LIB_INSTALL_DIR}/uca
+ COMPONENT ${UCA_CAMERA_NAME})