summaryrefslogtreecommitdiffstats
path: root/plugins/pf/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2013-03-15 09:07:51 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2013-03-15 09:07:51 +0100
commit7c5017db105a74af7c622d3529ac9c2c203f99d7 (patch)
treef1ea4521ef95a743abb8564457823de56b463982 /plugins/pf/CMakeLists.txt
parentd4f1fc90188820a00a74a7e5fd04f6feffa7537e (diff)
downloaduca-7c5017db105a74af7c622d3529ac9c2c203f99d7.tar.gz
uca-7c5017db105a74af7c622d3529ac9c2c203f99d7.tar.bz2
uca-7c5017db105a74af7c622d3529ac9c2c203f99d7.tar.xz
uca-7c5017db105a74af7c622d3529ac9c2c203f99d7.zip
Build package flags inside package-plugin.sh.in
This will use the information provided by each plugin.
Diffstat (limited to 'plugins/pf/CMakeLists.txt')
-rw-r--r--plugins/pf/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/plugins/pf/CMakeLists.txt b/plugins/pf/CMakeLists.txt
index ef11f8f..6abfcdf 100644
--- a/plugins/pf/CMakeLists.txt
+++ b/plugins/pf/CMakeLists.txt
@@ -7,6 +7,9 @@ find_package(ClSerMe4)
if (PF_FOUND AND CLSERME4_FOUND AND FGLIB5_FOUND)
set(UCA_CAMERA_NAME "pco")
+ set(PLUGIN_VERSION "1.0.0")
+ set(PLUGIN_REVISION "0")
+ set(PLUGIN_REQUIRES "libuca >= 1.1.0")
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/../package-plugin.sh.in
${CMAKE_CURRENT_BINARY_DIR}/../../package-plugin-${UCA_CAMERA_NAME}.sh)