summaryrefslogtreecommitdiffstats
path: root/plugins/pylon/CMakeLists.txt
diff options
context:
space:
mode:
authorMihael Koep <koep@schneide.com>2013-11-06 11:25:23 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-11-06 14:43:09 +0100
commit009d135d809313745809c46cad9fb39ffbeaa395 (patch)
treec592eaacd1c016b0e6c8c99a7cad7d95cd9c4443 /plugins/pylon/CMakeLists.txt
parent16d9c31f754a99ce6dc7e6de2c7da8a9468d7f89 (diff)
downloaduca-009d135d809313745809c46cad9fb39ffbeaa395.tar.gz
uca-009d135d809313745809c46cad9fb39ffbeaa395.tar.bz2
uca-009d135d809313745809c46cad9fb39ffbeaa395.tar.xz
uca-009d135d809313745809c46cad9fb39ffbeaa395.zip
Many updates and bugfixes to pylon camera plugin.
Diffstat (limited to 'plugins/pylon/CMakeLists.txt')
-rw-r--r--plugins/pylon/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/plugins/pylon/CMakeLists.txt b/plugins/pylon/CMakeLists.txt
index f45ef76..1f56f06 100644
--- a/plugins/pylon/CMakeLists.txt
+++ b/plugins/pylon/CMakeLists.txt
@@ -10,9 +10,16 @@ if (PYLON_FOUND)
${CMAKE_CURRENT_BINARY_DIR}/../../package-plugin-${UCA_CAMERA_NAME}.sh)
include_directories(${LIBPYLONCAM_INCLUDEDIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
${UCA_CONFIGDIR})
+ create_enums(uca-pylon-enums
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../src/uca-enums
+ uca-pylon-camera.h)
+
add_library(ucapylon SHARED
+ uca-pylon-enums.c
uca-pylon-camera.c)
target_link_libraries(ucapylon