summaryrefslogtreecommitdiffstats
path: root/plugins/xkit/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2014-04-02 08:32:50 +0200
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2014-07-22 16:30:13 +0200
commit3031b5459bf662640b73b470bede0be021fc4409 (patch)
tree37f4acd61643a07a5b73dfeee770205c2c3d9d71 /plugins/xkit/CMakeLists.txt
parent4cb99ce7983215e4786015c60293305728d0c408 (diff)
downloaduca-3031b5459bf662640b73b470bede0be021fc4409.tar.gz
uca-3031b5459bf662640b73b470bede0be021fc4409.tar.bz2
uca-3031b5459bf662640b73b470bede0be021fc4409.tar.xz
uca-3031b5459bf662640b73b470bede0be021fc4409.zip
Use direct UDP communication for xkit
Diffstat (limited to 'plugins/xkit/CMakeLists.txt')
-rw-r--r--plugins/xkit/CMakeLists.txt30
1 files changed, 10 insertions, 20 deletions
diff --git a/plugins/xkit/CMakeLists.txt b/plugins/xkit/CMakeLists.txt
index 6441c46..e4f6a39 100644
--- a/plugins/xkit/CMakeLists.txt
+++ b/plugins/xkit/CMakeLists.txt
@@ -1,33 +1,23 @@
cmake_minimum_required(VERSION 2.6)
-project(ucaxkit CXX)
+project(ucaxkit C)
set(UCA_CAMERA_NAME "xkit")
set(PLUGIN_VERSION "0.1.0")
set(PLUGIN_REVISION "1")
set(PLUGIN_REQUIRES "libuca >= 1.2.0")
-find_package(PkgConfig)
-pkg_check_modules(XKIT xkit>=0.1.0)
-if (XKIT_FOUND)
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/../package-plugin.sh.in
- ${CMAKE_CURRENT_BINARY_DIR}/../../package-plugin-${UCA_CAMERA_NAME}.sh)
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fopenmp")
- message("includedir: ${XKIT_LIBRARIES}")
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/../package-plugin.sh.in
+ ${CMAKE_CURRENT_BINARY_DIR}/../../package-plugin-${UCA_CAMERA_NAME}.sh)
- include_directories(${XKIT_INCLUDEDIR}
- ${UCA_CONFIGDIR})
+include_directories(${UCA_CONFIGDIR})
- # We have to compile with g++ because the included header files have C++
- # style comments ...
- add_library(ucaxkit SHARED
- uca-xkit-camera.cc)
+add_library(ucaxkit SHARED uca-xkit-camera.c)
- target_link_libraries(ucaxkit
- ${UCA_DEPS}
- ${XKIT_LIBRARIES})
+target_link_libraries(ucaxkit ${UCA_DEPS})
- install(TARGETS ucaxkit
- LIBRARY DESTINATION ${UCA_PLUGINDIR}
- COMPONENT ${UCA_CAMERA_NAME})
-endif ()
+install(TARGETS ucaxkit
+ LIBRARY DESTINATION ${UCA_PLUGINDIR}
+ COMPONENT ${UCA_CAMERA_NAME})