summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2012-07-04 10:49:26 +0200
committerMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2012-07-04 10:49:26 +0200
commit39c6bb082696283e74ee72a2097749a4de1a418b (patch)
treec3b7e2cf8e9710d6eac6b330ff58adf4b28d1ee8 /test/CMakeLists.txt
parentb67947751a24366137844cd1a3b41bed7095bf76 (diff)
downloaduca-39c6bb082696283e74ee72a2097749a4de1a418b.tar.gz
uca-39c6bb082696283e74ee72a2097749a4de1a418b.tar.bz2
uca-39c6bb082696283e74ee72a2097749a4de1a418b.tar.xz
uca-39c6bb082696283e74ee72a2097749a4de1a418b.zip
Add property tree view
The standard tree view widget is not capable of setting individual cell renderers per row. Thus I made one with a custom cell renderer that uses an appropriate cell renderer depending of the property type. I developed this independently and put it up on Github at https://github.com/matze/EggPropertyTreeView.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 428a56a..224bd46 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -36,7 +36,10 @@ target_link_libraries(grab-async uca ${GLIB2_LIBRARIES} ${GOBJECT2_LIBRARIES})
if (GTK2_FOUND)
include_directories(${GTK2_INCLUDE_DIRS})
- add_executable(control control.c)
+ add_executable(control
+ control.c
+ egg-property-cell-renderer.c
+ egg-property-tree-view.c)
target_link_libraries(control uca
${GTK2_LIBRARIES} ${GTHREAD2_LIBRARIES})
endif()