summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2012-04-19 16:45:11 +0200
committerMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2012-04-19 16:45:11 +0200
commit42e3c64fa57039d7673c61f909b5fd40a437bdfd (patch)
treeb9552183c0b1f56aa98395ac760e5d0ec79b2b0e /test/CMakeLists.txt
parente23aff7cfa16d7d3446f59e9100341f060a08e11 (diff)
downloaduca-42e3c64fa57039d7673c61f909b5fd40a437bdfd.tar.gz
uca-42e3c64fa57039d7673c61f909b5fd40a437bdfd.tar.bz2
uca-42e3c64fa57039d7673c61f909b5fd40a437bdfd.tar.xz
uca-42e3c64fa57039d7673c61f909b5fd40a437bdfd.zip
Export base properties and string array
The benefits are two-fold: Camera implementations "know" which base properties exist without looking into the implementation source. Moreover, they can re-use the property strings rather than stating them over and over again. These change should reduce potential c&p errors.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt14
1 files changed, 8 insertions, 6 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 7d438b6..7380179 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -43,12 +43,14 @@ include_directories(
${CMAKE_CURRENT_SOURCE_DIR}/../src/cameras
)
-add_executable(test-mock test-mock.c)
-target_link_libraries(test-mock
- uca-gobject
- ${GLIB2_LIBRARIES}
- ${GOBJECT2_LIBRARIES}
- )
+if (HAVE_MOCK_CAMERA)
+ add_executable(test-mock test-mock.c)
+ target_link_libraries(test-mock
+ uca-gobject
+ ${GLIB2_LIBRARIES}
+ ${GOBJECT2_LIBRARIES}
+ )
+endif()
add_executable(test-all test-all.c)
target_link_libraries(test-all