summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2012-03-05 18:03:51 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2012-03-05 18:03:51 +0100
commitce4475a53441f6f9a79db85fd4bfe82cba046f23 (patch)
tree33e2d6d4cdc09ac45f250e82486575ff48b3d9ce /test/CMakeLists.txt
parent03739354e074c547d99a6992a7774c3643d17da1 (diff)
downloaduca-ce4475a53441f6f9a79db85fd4bfe82cba046f23.tar.gz
uca-ce4475a53441f6f9a79db85fd4bfe82cba046f23.tar.bz2
uca-ce4475a53441f6f9a79db85fd4bfe82cba046f23.tar.xz
uca-ce4475a53441f6f9a79db85fd4bfe82cba046f23.zip
Add test facility that uniformly tests all cameras
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 4ee097b..6e2e0d5 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -57,3 +57,10 @@ target_link_libraries(test-mock
${GLIB2_LIBRARIES}
${GOBJECT2_LIBRARIES}
)
+
+add_executable(test-all test-all.c)
+target_link_libraries(test-all
+ uca-gobject
+ ${GLIB2_LIBRARIES}
+ ${GOBJECT2_LIBRARIES}
+ )