summaryrefslogtreecommitdiffstats
path: root/tools/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorMihael Koep <koep@schneide.com>2012-10-19 17:03:49 +0200
committerMihael Koep <koep@schneide.com>2012-10-19 17:03:49 +0200
commit9866002f3f569f6da886d71964d3298183cd1646 (patch)
tree968097e2f5fa11a094238ead6469739a725d8ce2 /tools/gui/CMakeLists.txt
parent37f48ae1b67b1205ba4884ec350afdf5ab7dd2d3 (diff)
parent6f12303cf4c4130d544c30f8ad5e2445a1fa3e61 (diff)
downloaduca-9866002f3f569f6da886d71964d3298183cd1646.tar.gz
uca-9866002f3f569f6da886d71964d3298183cd1646.tar.bz2
uca-9866002f3f569f6da886d71964d3298183cd1646.tar.xz
uca-9866002f3f569f6da886d71964d3298183cd1646.zip
Merge remote branch 'origin/master' into dexela
Conflicts: CMakeLists.txt src/CMakeLists.txt src/uca-camera.c
Diffstat (limited to 'tools/gui/CMakeLists.txt')
-rw-r--r--tools/gui/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/tools/gui/CMakeLists.txt b/tools/gui/CMakeLists.txt
new file mode 100644
index 0000000..1000ac6
--- /dev/null
+++ b/tools/gui/CMakeLists.txt
@@ -0,0 +1,43 @@
+cmake_minimum_required(VERSION 2.8)
+
+add_definitions("--std=c99 -Wall")
+
+# --- Find packages and libraries ---------------------------------------------
+find_package(PkgConfig)
+
+pkg_check_modules(GTK2 gtk+-2.0>=2.22)
+pkg_check_modules(GTHREAD2 gthread-2.0)
+pkg_check_modules(GLIB2 glib-2.0>=2.24 REQUIRED)
+pkg_check_modules(GOBJECT2 gobject-2.0>=2.24 REQUIRED)
+
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/control.glade ${CMAKE_CURRENT_BINARY_DIR})
+
+# --- Build targets -----------------------------------------------------------
+include_directories(
+ ${GLIB2_INCLUDE_DIRS}
+ ${GOBJECT2_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_BINARY_DIR}/../../src/
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../src
+ )
+
+if (GTK2_FOUND)
+ include_directories(${GTK2_INCLUDE_DIRS})
+
+ add_executable(control
+ control.c
+ ring-buffer.c
+ egg-property-cell-renderer.c
+ egg-property-tree-view.c
+ egg-histogram-view.c)
+
+ target_link_libraries(control uca
+ ${GTK2_LIBRARIES}
+ ${GTHREAD2_LIBRARIES}
+ m)
+
+ install(TARGETS control
+ RUNTIME DESTINATION bin)
+
+ install(FILES control.glade
+ DESTINATION share/libuca)
+endif()