summaryrefslogtreecommitdiffstats
path: root/plugins/pylon/CMakeLists.txt
diff options
context:
space:
mode:
authorMihael Koep <koep@schneide.com>2013-11-06 11:39:28 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-11-06 14:43:09 +0100
commitfb3689eed1627b4a6d63de9191d78620b6d25c45 (patch)
treeb60132bd0e374241f2cccb5b94eddd388a4b8f72 /plugins/pylon/CMakeLists.txt
parent009d135d809313745809c46cad9fb39ffbeaa395 (diff)
downloaduca-fb3689eed1627b4a6d63de9191d78620b6d25c45.tar.gz
uca-fb3689eed1627b4a6d63de9191d78620b6d25c45.tar.bz2
uca-fb3689eed1627b4a6d63de9191d78620b6d25c45.tar.xz
uca-fb3689eed1627b4a6d63de9191d78620b6d25c45.zip
Improve package information of pylon plugin.
Diffstat (limited to 'plugins/pylon/CMakeLists.txt')
-rw-r--r--plugins/pylon/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/plugins/pylon/CMakeLists.txt b/plugins/pylon/CMakeLists.txt
index 1f56f06..7e573f1 100644
--- a/plugins/pylon/CMakeLists.txt
+++ b/plugins/pylon/CMakeLists.txt
@@ -1,10 +1,18 @@
cmake_minimum_required(VERSION 2.6)
project(ucapylon C)
+set(VERSION "1.0.0")
find_package(Pylon)
if (PYLON_FOUND)
set(UCA_CAMERA_NAME "pylon")
+ set(PLUGIN_VERSION ${VERSION})
+ set(PLUGIN_REVISION "2")
+ set(PLUGIN_SUMMARY "Pylon plugin for libuca")
+ set(PLUGIN_CHANGELOG "${CMAKE_CURRENT_SOURCE_DIR}/changelog.txt")
+ set(PLUGIN_DESCRIPTION "Plugin for the Basler GigE CCD Camera.")
+ set(PLUGIN_REQUIRES "libuca >= 1.3.0, libpyloncam >= 0.2.3")
+ set(PLUGIN_VENDOR "ANKA Computing Group")
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/../package-plugin.sh.in
${CMAKE_CURRENT_BINARY_DIR}/../../package-plugin-${UCA_CAMERA_NAME}.sh)